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Dados

Os dados para esta aula encontram-se no servidor 

\\dspace\home sob a pasta

cadeiras\Geomatica\geom1415\aula01

• Copiar para a pasta de trabalho local a pasta aula01

– cada uma das pastas , , e – cada uma das pastas CONC, LIM, RIOS, SOLO e TOPO_C (as 
últimas 4 encontram-se sob a pasta dadosAA) contém os 

diversos ficheiros que constituem um conjunto de dados 

geográficos (cdg) em formato shapefile

– a pasta TEMP (sob a pasta dadosAA) contém um cdg em 

formato raster

– estes dados foram retirados da CAOP2013 e do Atlas do 

Ambiente (http://www2.apambiente.pt/atlas/est/index.jsp)
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Ficheiros e Pastas

• os dados (espaciais e não-espaciais) são 

guardados em ficheiros

– shapefiles (.shp), ficheiros de georreferenciação – shapefiles (.shp), ficheiros de georreferenciação 

(.prj), tabelas (.dbf), …

• os ficheiros são sempre guardados em pastas
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QGIS

• Inclui ferramentas para:

– criar

– visualizar

– inquirir– inquirir

– alterar

– efectuar operações espaciais envolvendo

– publicar

mapas
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Iniciar e configurar o QGIS 

Iniciar o QGIS
• botão Windows → All Programs→ QGIS Dufour → QGIS Desktop 2.0.1, ou

• duplo clique no atalho           que se encontra no desktop, ou

• duplo clique sobre um ficheiro do tipo projeto (.qgs)

• mas  primeiro é necessário já ter criado um ficheiro do tipo projeto!

Configurar o QGISConfigurar o QGIS
• Alterar o idioma da interface do QGIS: em Configurações → Opções → Região

ativar Sobrepor idioma do sistema e alterar Idioma a utilizar em alternativa 
para U.S. English, clicar em [OK], fechar o QGIS e voltar a iniciar

• Ativar plugins: em Plugins → Manage and Install Plugins … ativar Coordinate
Capture, Dxf2Shp Converter, fTools, GdalTools, Georeferencer GDAL, 
Interpolation plugin, Processing, Raster Terrain Analysis plugin, Spatial Query
Plugin, Topology Checker, Zonal statistics plugin e clicar em [Close]

• Alterar a cor de seleção: em Project → Project Properties → General alterar 
Selection color e clicar em [OK]
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Interface do QGIS 2.0.1
menu bar

tool bar(s)
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status bar

map legend

map view



Adicionar um layer vetorial

Adicionar um layer (camada ou conjunto de dados) 

vetorial
• clique no ícone          Add Vector Layer

• na janela de diálogo Add Vector Layer é necessário estar 
selecionado     File como Source Typeselecionado     File como Source Type

• clique [Browse] para selecionar o layer vetorial solo (formato 
shapefile)

• na combobox filetype selecione: “ESRI Shapefiles [OGR] (*.shp
*.SHP)”

• selecione solo.shp (na pasta x\aula01\dadosAA\SOLO)  e clique 
[Open]

• volte a clicar [Open]
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Ficheiro do tipo projeto 

(com extensão .qgs)
• Um ficheiro do tipo projeto não contém dados

– contém o estado da sessão de trabalho com o QGIS no 
momento em que o ficheiro é criado/salvo

• contém apontadores para ficheiros que contêm dados 
geográficos

• contém legendas• contém legendas

• contém ... (a ver mais tarde)

– Criar um ficheiro do tipo projeto (.qgs)

– no menu Project → Save, ou

– no ícone 
• escolher a pasta, por exemplo x\aula01 e escrever em File 

name: Pt.qgs, por exemplo

– para mudar o nome: Project → Save As ou ícone     Save As
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Mapa, tema e features

• Um mapa pode conter uma grande diversidade 

de temas geográficos

• Cada tema é uma conjunto de dados 

geográficos (cdg) agrupados recorrendo a algum geográficos (cdg) agrupados recorrendo a algum 

critério

• Features são objectos geográficos (objectos

concretos, fenómenos, ...), isto é, objectos que 

possuem coordenadas
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• As features/dados/entidades geográficas/objetos geográficos organizam-se em 
layers ou camadas armazenados em ficheiros

• Um layer vetorial contém dados de duas naturezas:
– dados espaciais, do tipo ponto, linha ou polígono, para descrever a localização (e forma) das 

features – também chamada “geometria das features”

– atributos (numéricos, alfanuméricos ou datas) para descrever as outras características das 
features

os valores dos atributos podem ser associados a símbolos

descritos na legenda do respetivo layer

Layers e features no QGIS

descritos na legenda do respetivo layer

• Observar as propriedades do layer solo

– Duplo clique no nome do layer que se encontra na área de map legend ou clique com o 

botão do lado direito do rato no nome do layer → Properties (observe, em particular, as 

janelas General e Fields)

• Um projecto pode conter mais do que um layer

• Observar as propriedades do projeto Pt.qgs
– menu Project → Project Properties (observe, em particular, as janelas General e CRS)

• na janela CRS pode ativar 
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Explorando um mapa

• A barra de ferramentas Map Navigation
– Adicionar a barra Map Navigation ao ambiente de 

trabalho:

• menu View → Toolbars → ativar                   , ou

• clique com o botão do lado direito do rato na área de • clique com o botão do lado direito do rato na área de 
tool bar(s) → ativar 

– Utilizar algumas funções da barra Map Navigation:

• Pan Map (para deslocação na área de map view)

• Zoom In,       Zoom Out e        Zoom Full (para alterar a 
escala de visualização)

• Zoom to Selection

• Zoom Last e         Zoom Next
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Explorando um mapa

A barra de ferramentas Attributes
– Adicionar a barra Attributes ao ambiente de trabalho

• menu View → Toolbars → ativar                 , ou

• clique com o botão do lado direito do rato na área de tool
bar(s) e ativar 

Utilize algumas funções da barra :– Utilize algumas funções da barra Attributes:

• Identify Features

• Select Single Feature e Deselect Features from All
Layers

– por omissão o QGIS utiliza a cor amarela para assinalar as features que se 
encontram selecionadas; esta cor pode ser alterada no menu Project → 
Project Properties→ General em Selection color

• Open Attribute Table

• Measure Angle → Measure Line
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Questões

• Abrir a tabela do layer solo

– Qual é o tipo dos objetos/features (pontos, linhas 

ou polígonos) do layer solo? 

– Quais são os atributos desse layer?– Quais são os atributos desse layer?

– Quantas features existem neste layer?

– Selecionar a linha nº 3 da tabela e observar o que 

sucede no mapa

• Adicione ao projeto os layers vetoriais CONC, 

LIM, RIOS e TOPO_C
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Adicionar um layer raster (matricial)

– Adicionar um layer raster

• clique no ícone          Add Raster Layer

• clique [Browse] para selecionar o layer raster temp (formato raster)

• na combobox filetype selecione “[GDAL] Arc/Info Binary Grid hdr.adf
HDR.ADF”

• selecione hdr.adf (na pasta x\aula01\dadosAA\TEMP\temp)  e clique • selecione hdr.adf (na pasta x\aula01\dadosAA\TEMP\temp)  e clique 
[Open]

– Alterar o nome do layer na área de map legend

• em Layer Properties → General → Layer info como Layer name indicar 

(escrever) temp

– Interpretar a informação que consta em Layer Properties → 
Histogram

• clique em
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O Browser do QGIS

O Browser do QGIS facilita a “navegação” nas pastas e ficheiros de 

dados e pode ser utilizado em alternativa ao Windows Explorer

• para ativar o Browser:

– em menu View → Panels, ativar , ou

– clique com o botão do lado direito do rato na área de tool bar(s) e ativar– clique com o botão do lado direito do rato na área de tool bar(s) e ativar

• note que pode utilizar 2 áreas diferentes para fazer Browser …

• Project home corresponde a que pasta?

• compare a informação disponibilizada

pelo Browser do QGIS com a do Windows

Explorer

– quais são as principais diferenças?

15

Browser



Visualização simultânea 

de vários layers

− Verificar que os 6 layers se encontram on, isto é, 

estão todos visualizáveis ...

• Ou não? Porquê?

• Colocar off os layers temp, rios e solo• Colocar off os layers temp, rios e solo

• Deslocar o layer topo_c para baixo do layer conc, 

arrastando-o com o rato na área de map legend

• O layer topo_c já não se vê mas continua on! Que 

sucedeu?

• Colocar o layer topo_c sobre todos os outros
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Criar legendas de tipo qualitativo 

para layers vectoriais
Criar uma simbologia e uma legenda para o layer conc_2013
indicativas do distrito a que cada concelho pertence

• observar a tabela de atributos do layer conc_2013, em particular,
a coluna Distrito e respetivos valores (note que alguns são NULL)

• em Layer Properties → Style

– onde se encontra selecionar– onde se encontra selecionar

» Single Symbol é o tipo de legenda por omissão adotado pelo QGIS
sempre que é adicionado um novo layer ao projeto

– em Column selecionar DISTRITO e clique em [Classify]
– escolha outro conjunto de cores em Color Ramp, clique em [Delete

all], clique novamente em [Classify] e depois em [OK]
• alterar a cor do distrito de Lisboa para sem cor (transparente)

– em Layer Properties → Style duplo clique sobre o símbolo
representativo do distrito de Lisboa, alterar Transparency 0% para
Transparency 100% e clicar em [OK] e, novamente, [OK]

– colocar on o layer solo; que sucede?
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Criar legendas de tipo quantitativo 

para layers vectoriais
Criar uma simbologia e uma legenda para o layer conc_2013
indicativas da área de cada concelho

• observar a tabela de atributos do layer conc_2013, em

particular, a coluna areaHa e respectivos valores

• em Layer Properties → Style

– onde se encontra ou selecionar

– em Column selecionar areaHa
– em Classes selecionar 9
– clique em [Classify] e observe a legenda obtida
– em Mode escolha Pretty Breaks e observe de novo a legenda

» por omissão as legendas quantitativas são criadas pelo método Equal

Interval

» qual diferença entre o método Equal Interval e Pretty Breaks? 18



Criar legendas para layers raster

Criar uma simbologia e uma legenda para o layer temp
(temperaturas médias anuais)

• o layer temp não possui tabela de atributos

– os layers raster, pela sua natureza, não possuem tabela de

atributos!

• em Layer Properties → Style• em Layer Properties → Style

– em Render type selecione Singleband pseudocolor

– em Mode selecione Equal Interval

– em Classes selecione 7

– em Min escreva 8 e em Max escreva 20

– clique em [Classify] e depois em [OK]

– abrir a legenda na área de map legend

» em clique sobre
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Etiquetagem de layers vectoriais

Criar etiquetas para o layer conc_2013 indicativas do 

concelho que corresponde a cada polígono

• em Layer Properties → Labels

– active

– e imediatamente à direita selecione – e imediatamente à direita selecione 

– em Size escreva 5

– clique em [OK]

• fazer ZOOM IN numa região pequena

– as operações de Zoom não afetam a fonte das letras das 

etiquetas
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Seleção de features recorrendo a expressões 

envolvendo valores de atributos

Selecionar todas as features do layer rios (linhas) que 

representam o rio Tejo

– seleccionar todas as linhas do layer rios cujo atributo Designação
contém o valor ‘Rio Tejo’

• coloque off todos os layers exceto o layer rios e ative este layer

• clique no ícone          Select features using an expression• clique no ícone          Select features using an expression

• na janela Select By Expression escreva na área Expression:

• clique em 
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Seleção de features recorrendo a expressões 

envolvendo valores de atributos (cont.)

Selecionar todas as features do layer rios (linhas) que 

representam o rio Tejo (cont.)

– observar que as linhas seleccionadas apresentam duas 

decontinuidades; porquê? 

• sugestão: recorra à função Identify Features

– selecionar todas as linhas do layer rios que representam o rio Tejo, 

incluindo as linhas em falta observadas
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Seleção de features recorrendo a operações 

espaciais

Selecionar todas as features do layer conc_2013 (polígonos) 

banhados pelo rio Tejo

– manter selecionadas todas as linhas que representam o rio Tejo

– sobre a área tool bar(s) clicar com o botão do lado direito do rato e 

selecionar Vector (para tornar visível o ícone         Spatial Query )

– na janela Spatial Query selecione:– na janela Spatial Query selecione:

– clicar em 

– clicar em 
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Criação de um novo layer/cdg

Criar um novo layer/cdg em formato shapefile contendo 

apenas os concelhos banhados pelo rio Tejo

– criar a pasta x\aula01\concTejo

– com todos os concelhos banhados pelos rio Tejo ainda 

selecionados, na área de map legend clicar com o botão do lado selecionados, na área de map legend clicar com o botão do lado 

direito do rato sobre o layer conc_2013 e selecionar Save 
Selection As …

– clicar em [Browse], escolher a pasta x\aula01\ concTejo e 

escrever em File name: concRTejo

– clicar em [Save] e em [OK]

– observar a pasta x\aula01\ concTejo

– adicionar ao projeto o layer concRTejo e observar a respetiva 

tabela de atributos
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Cruzamento de tabelas (preparação dos dados)

Adicionar um ficheiro de tipo CSV ao projeto

• Na pasta x\aula01\ encontra-se o ficheiro VACc.csv

– um ficheiro em formato csv pode ser criado a partir de uma folha 

de cálculo (.xls, .xlsx ou .ods, por exemplo)

• o ficheiro VACc.csv foi criado a partir de ValorAcrescentadoConcelhos.xls
(ficheiro Excel) 

• abra o ficheiro ValorAcrescentadoConcelhos.xls e observe o seu conteúdo

• No QGIS clique em        Add Delimited Text Layer

• Na janela Create a Layer from Delimited Text File, clique em 

[Browse] para selecionar a pasta x\aula01 e o ficheiro VACc.csv,
e as opções:

– se o ficheiro .csv contiver carateres especiais portugueses, deve em 

Encoding escolher Windows-1252
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Cruzamento de tabelas (a operação Join)

Juntar a cada feature do layer conc_2013 os dados do 
ficheiro VACc.csv (valores acrescentados por concelho) que 
lhe correspondem

• Em Layer Properties – conc_2013 → clicar em

– qual o atributo da tabela de atributos do layer conc_2013 e qual a coluna 
do ficheiro VACc.csv devem ser utilizados neste cruzamento?

• Abrir a tabela de atributos do layer conc_2013 e observar o 
resultado do cruzamento efetuado; que conclui?
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Cruzamento de tabelas (algumas consequências)

Mantendo o Join criado anteriormente, criar legendas e 

etiquetas indicativas dos valores acrescentados por 

concelho

• Crie uma legenda para o layer conc_2013 indicativa do 

valor acrescentado total (atributo MEuros) de cada valor acrescentado total (atributo MEuros) de cada 

concelho

• Crie etiquetas para para o layer conc_2013 indicativas do 

valor acrescentado da produção de cortiça em 

percentagem (atributo Pcortica)
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Criar um novo atributo no layer conc_2013 para guardar neste novo 

atributo o valor acrescentado da produção agrícola em Meuros

• criar um novo atributo com o nome PAgrMEuros e tipo numérico com 

casas decimais – Decimal number (real): 15 dígitos significativos (width) e 

3 casas decimais (precision)

– em Layer Properties – conc_2013 → Fields, ative o modo de edição 

clicando em        

Criação de novos atributos de um layer

clicando em        Toggle editing mode

– clique em       New column

– preencha

– clique em [OK]

– em Layer Properties – conc_2013 → Fields, desative o modo de edição 

clicando em        Toggle editing mode

– guarde as alterações clicando [Save] em
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Calcular o valor acrescentado da produção agrícola de cada 

concelho em Meuros

• Calcular o valor acrescentado da produção agrícola e guardá-lo no 

novo atributo PAgrMEuros (MEuros x PAgri)

– em Layer Properties – conc_2013 → Fields, ative o modo de edição 

clicando em       Toggle editing mode

Cálculo de valores de um atributo

clicando em       Toggle editing mode

– clique em       Field calculator

– preencha

– clique em [OK]

– em Layer Properties – conc_2013 → Fields, desative o modo de edição 

clicando em       Toggle editing mode

– guarde as alterações clicando [Save] em
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Impressão de mapas

• Para adicionar uma barra de escala: View → Decorations → 
Scale Bar 

• Para adicionar uma seta de orientação Norte: View →
Decorations → North Arrow

• Para criar um ficheiro imagem (.bmp, .tiff, .jpg, …): Project →• Para criar um ficheiro imagem (.bmp, .tiff, .jpg, …): Project →
Save as Image

• Para criar um mapa para impressão: Project → New Print 
Composer …
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O Help do QGIS

O Help do QGIS baseia-se no User Guide que se encontra online 

em http://docs.qgis.org/2.0/en/docs/user_manual/ e de que se 

pode fazer download, podendo depois ser utilizado sem ser 

necessário dispor de uma ligação à Internet. A versão online

também pode ser acedida:também pode ser acedida:

• recorrendo à barra de ferramentas Help , ou

• em Help → Help Contents
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